r   e   k   l   a   m   a
r   e   k   l   a   m   a

Brak wsparcia Firefoksa dla starszych dystrybucji Linuksa?

Strona główna Aktualności

Być może już niedługo Firefox przestanie wspierać starsze dystrybucje Linuksa i ich użytkownicy będą musieli podjąć dodatkowe działania, jak np. aktualizacja pakietów, aby uruchamiać najnowsze wersje przeglądarki.

Taką informację podał Mike Conner kierujący rozwojem przeglądarki. Dotychczas stosowane były różne rozwiązania w kodzie Firefoksa, które umożliwiały jego działanie nawet na dosyć starych wersjach bibliotek. Jednak kompatybilność wstecz choć jest pożądana przez użytkowników to zawsze sprawia dużo trudności programistom. Oznacza bardziej rozbudowany i mniej przejrzysty kod a także dłuższe testowanie. Jest też źródłem błędów. Dlatego też Conner po rozmowach z twórcami dystrybucji Fedora i Ubuntu zaproponował zestaw wymagań, które będzie musiała spełnić dystrybucja aby Firefox mógł na niej działać.

Jeśli propozycja wejdzie w życie, dostosowywanie Firefoksa do działania na starszych dystrybucjach spadnie na twórców tych dystrybucji. Natomiast programiści Firefoksa zostaną odciążeni i będą mogli się bardziej skupić na rozwoju przeglądarki.

r   e   k   l   a   m   a
© dobreprogramy
r   e   k   l   a   m   a
r   e   k   l   a   m   a

Komentarze

r   e   k   l   a   m   a
r   e   k   l   a   m   a
Czy wiesz, że używamy cookies (ciasteczek)? Dowiedz się więcej o celu ich używania i zmianach ustawień.
Korzystając ze strony i asystenta pobierania wyrażasz zgodę na używanie cookies, zgodnie z aktualnymi ustawieniami przeglądarki.