r   e   k   l   a   m   a
r   e   k   l   a   m   a

Programiści PHP rozważają zmianę cyklu wydawniczego

Strona główna Aktualności

Johannes Schlüter, dotychczasowy menadżer wydania PHP 5.3 zaproponował na grupie dyskusyjnej php.internals uporządkowanie cyklu wydawniczego PHP.

Dotychczas problemem PHP było długie utrzymywanie starszych wersji w firmach hostingowych, co hamuje rozwój aplikacji i w efekcie samego języka. Nawet teraz można spotkać firmy, które oferują klientom PHP z gałęzi 4.x do którego od 2008 roku nie są już wydawane poprawki błędów bezpieczeństwa. Według propozycji Schlütera PHP miałby zbliżony cykl wydawniczy do tego, jaki istnieje w Ubuntu. Według niego 2 wersje PHP byłyby wspierane. Pierwsza wersja posiadałaby długi okres wsparcia (LTS) a druga otrzymywałaby aktualizacje wyłącznie do momentu wydania kolejnej wersji ze skróconym wsparciem technicznym.

Schlüter oczekuje, że wprowadzone zmiany miałyby skutkować szybszym wprowadzaniu nowości do parsera czy zmotywowaniu programistów tworzących rozszerzenia do wdrażania nowości jakie pojawiają się w języku. Użytkownicy będą mieli również wybór pomiędzy bardzo stabilną wersją z długim okresem wsparcia, której aktualizacje nie będą wiązały się ze złamaniem wstecznej kompatybilności a wersją w której często pojawiać się będą nowości oraz którą trzeba będzie częściej aktualizować a zmiany jakie będą nieść aktualizacje będą mogły powodować niedziałanie niektórych aplikacji.

r   e   k   l   a   m   a

Jak wynika z reakcji na tą propozycję można się wywnioskować, że zostanie ona zaakceptowana a pierwszą wersją LTS będzie 5.3. Najnowsze wersje PHP zarówno w postaci źródeł jak i wersji instalacyjnych można pobrać ze stron projektu.

© dobreprogramy
r   e   k   l   a   m   a
r   e   k   l   a   m   a

Komentarze

r   e   k   l   a   m   a
r   e   k   l   a   m   a
Czy wiesz, że używamy cookies (ciasteczek)? Dowiedz się więcej o celu ich używania i zmianach ustawień.
Korzystając ze strony i asystenta pobierania wyrażasz zgodę na używanie cookies, zgodnie z aktualnymi ustawieniami przeglądarki.