Strona używa cookies (ciasteczek). Dowiedz się więcej o celu ich używania i zmianach ustawień. Korzystając ze strony wyrażasz zgodę na używanie cookies, zgodnie z aktualnymi ustawieniami przeglądarki.    X

Nie obiektywny test Visual Studio 2010 Professional pt 1.

Yeah. Wszyscy na około zdają się chwalić VS. Szczególnie za Intelisens (czy jak kol wiek się to pisze).
Potrzebuje teraz IDE pod Wingrozą, więc pomyślałem, że spróbuję, bo licencję mam z MSDNAA.

Sam lubię programować (prawie wszystko) a zazwyczaj koduję pod Linuksem, często bez żadnego IDE (konsola + vim), lub w Eclipse lub Qt Creator (choć inne też próbowałem).

Więc ocena będzie subiektywna, kreowana okiem uniksowego programisty.

r   e   k   l   a   m   a

Win7 Professional 64bity z MSDNAA.

Instalacja.

Pobranie VS z MSDNAA to bardzo prosta czynność (co doceniłem w pełni puźniej). Niestety pobieramy tylko downloader -- nici z pobierania pod Linuksem. Jednak sam programik staje na wysokości zadania.

Dostajemy obraz płyty .img, dla DAEMON TOOLS Lite pryszcz.

Sam instalator raczej solidny choć kiepsko pomyślany. Pierwsze Dalej w ogóle niepotrzebne (ładowanie składników instalatora), później formalności i prawnicze kruczki (nie posiadam VS a tylko licencję na użytkowanie, etc.).

Pierwsze istotne okienko to okienko instalacji poszczególnych składników. A jest ich parę. VC 9.0, 10.0, 10.0 x64, .NET4.0, etc.

Instaluje VC 9.0. Pierwszy restart (sic!). Po restarcie pisze, że nie ma płyty (nic dziwnego jeszcze w DT nie zamontowałem), montuję, ponawiam próbę, działa.
Następnie Instalator instaluję VC 9.0 (? ale pewnie tylko kończy instalować). I tu wyskakuje błąd.

Error

Zaglądam do ogólnego komunkatu:
MSI error 1603 -> "poważny błąd podczas instalacji" (nie no, na serio?)
Więcej logów, ten sam błąd.

Opis z neta, "błąd uniemożliwiający instalację" (nie zgadł bym, a wy?).
"VS 2010 error 1603" w Google (a później Binga). Pierwsza strona pomoc od MS.
Sprawdzić czy .Net jest poprawnie zainstalowany i czy instalator może go zainstalować.

OK ale ja instaluję VC 9.0!

Raz

Inne podejście. Wpadam do folderu instalatora, sam próbuję zainstalować VC 9.0.

"Aby zainstalować ten składnik uruchom instalator" (!!!)

Dwa

Wracam do stronki z google. Karzą weryfikować .Net. Weryfikuję, mam poprawne 2.0, 3.0, 3.5. 4.0 już nie weryfikuje, a takie właśnie się będzie instalowało z VS.

Trzy

OK jeszcze inny pomysł sprawdzę.

Strona MS, download, VS 9.0. Jest, instaluję. Szukam 10.0. Nic, Szukam 10.0 64bity. Nic. ?? A opcja szukaj nie działa (stronka się nie ładuje). Ale dobry MS szukajke zrobił jako skrypt przyjmujący dane w postaci zapytania GET. No to zmieniam parametry w adresie http. Teraz działa. Znajduje potrzebne pakiety i je instaluję. I jeszcze na wszelki wypadek .Net 4.0 też zainstalowałem.
Bezbłędnie.

Wracam do instalatora (po restarcie oczywiście).
.Net widzi jako zainstalowane VC nie. :(
I dalej zainstalować VC nie ma ochoty.
Laptop za drogi więc idę spalić jakiegoś pluszaka.... (oczywiście tylko sztucznego).

Na dziś wystarczy.

Plusy:
+ łatwość znalezienia instalki

Minusy:
- komunikat błędu o wystąpieniu błędu(sic!)
- brak dodatkowych informacji/ informacje zakopane w 15 różnych logach
- instalator "nie widzi" komponentów zainstalowanych oddzielnie

PS w trakcie produkcji tego wpisu, żadne pluszaki nie ucierpiały.

[UPDATE]
Reinstalacja Wingrozy zadziałała. VS "na świeżym" instaluje się bez problemu.
Będzie część 2.
[UPDATE 2]
Zmieniłem troszkę tytuł, aby mi ktoś nie pisał w komentarzach, że moje wypociny są nieobiektywne... 

Komentarze