Strona używa cookies (ciasteczek). Dowiedz się więcej o celu ich używania i zmianach ustawień. Korzystając ze strony wyrażasz zgodę na używanie cookies, zgodnie z aktualnymi ustawieniami przeglądarki.    X

Zasilacz OCZ ModXStream PRO u chirurga, czyli naprawa sygnału PG (PWR_OK)

Historia zaczęła się ponad dwa lata temu, kiedy to doznałem nieoczekiwanej sytuacji, co dla "komputerowca" oznacza szok i stan przed zawałowy. Komputer prawie umarł. Prawie, ponieważ po wciśnięciu "start" włączały się wentylatory i nic poza tym. Pierwsze próby zdiagnozowania rozpoczęły się od wypięcia wszystkich napędów i kart. Niestety nic się nie wyjaśniło.

Po wykluczeniu wszystkiego co można dołączyć do płyty głównej, podejrzany został tylko zasilacz. Metody "resetowania" w postaci odłączania całkowicie od zasilania nie pomogły. Po pomiarze napięć okazuje się, że są prawidłowe. Czyli wszystkie wartości są zgodne ze specyfikacją. W mojej głowie zabłysnęła żaróweczka "WDF!" i poszedłem spać.

Nazajutrz obudziła mnie myśl weryfikacji jeszcze jednego sygnału. Sygnału "PG" (Power Good), oznaczany też "PWR_OK". Sygnał ten jest podawany przez zasilacz i informuje płytę główną, że wszystkie napięcia są prawidłowe i można się uruchomić. Sygnał ten jest dostępny na pinie nr 8 złącza ATX, w kolorze popielatym lub białym. Mierząc napięcie między tym przewodem, a masą (kolor czarny) - powinno być 5V. W moim przypadku woltomierz wskazał wartość 0,07V - a jednak.

Otworzyłem więc moją Puszkę Pandory i pobieżnie dokonałem oględzin układu scalonego PS224, który odpowiada za kontrolę napięć wszystkich linii (3,3V-5V-12V) oraz monitoruje czy nie nastąpiło ich przeciążenie. Oględziny nie wykazały fizycznych uszkodzeń. Wówczas pilnie potrzebowałem uruchomienia mojego systemu i nie miałem czasu na zabawy w naprawę, więc postanowiłem zakupić nowy zasilacz, a OCZ wtrącić do izolatki w celu późniejszego obadania dokładniej sprawy (no 4,5 roku pochodził jednak).

Po ponad dwóch latach (!) od tego incydentu, wreszcie nadszedł czas na ostateczne rozwiązanie. Wyciągnąłem więc "oczko" z szafy i ponownie rozłożyłem, tym razem dokładnie wszystko - kawa na ławę. Dokładne prześledzenie drogi sygnału PG ujawniło przepalony (mała dziurka na środku) opornik R315 o rezystancji 10 ohm. Tym obwodem jest kierowane napięcie bezpośrednio z przetwornicy do wejścia PGI układu PS224.

Pomiar omomierzem potwierdził uszkodzenie (przerwę w obwodzie). Znając winowajcę wystarczy teraz tylko wymienić malutki rezystor SMD i po problemie. Ale zaraz zaraz, przecież nie mam takich rezystorów w składziku... Będzie konieczny przeszczep, a za dawcę posłużył mi stary dysk WD Caviar o pojemności 425,3 MB. Na płytce znalazłem kilka rezystorów o potrzebnej wartości.

Po wymianie opornika, przeszedłem do testów. Aby uruchomić zasilacz, musimy podać mu sygnał PS_ON (Power Supply On) przez połączenie pinu 14 (kolor zielony) do masy (GND). Do tego celu zrobiłem sobie zworkę z listwy pinowej i umieściłem we wtyczce ATX.

Start zasilacza i pomiar sygnału PG - niestety nadal nic. Po przyglądnięciu się wymienionemu elementowi stwierdziłem, że zbyt mocno się nagrzewa - cyna zaczęła się roztapiać na padach lutowniczych. Zapoznałem się wiec dalej z kolejnymi elementami i odkryłem uszkodzenie na diodzie prostowniczej D308. Okazało się, że prąd płynący w tym obwodzie przechodzi przez diodę i ładuje przez rezystor - kondensator. W chwili włączenia przez te elementy płynie większy prąd tylko w czasie ładowania kondensatora, tutaj brak prostowania napięcia przez uszkodzoną diodę powodował stały przepływ prądu przez obwód, który zamykał kondensator połączony z masą (GND).

Niestety nie znalazłem odpowiedniej diody w moich zasobach i byłem zmuszony zastosować element przewlekany. Dolutowaną diodę musiałem położyć na boku, aby się zmieściła - na szczęście udało się. Czas na test i pomiar napięć - udało się! Sygnał PWR_ON pokazał 5V, napięcia na wszystkich liniach się zgadzały - naprawa zakończona.

 

sprzęt porady hobby

Komentarze

0 nowych
adamk1985   11 #1 21.08.2016 19:23

Ciekawy wpis ;-)

bravo   16 #2 21.08.2016 19:38

@adamk1985: Dzięki za odwiedziny ;-) Może komuś się wpis przyda, jak doznał tego samego problemu.

Pangrys WSPÓŁPRACOWNIK  18 #3 21.08.2016 19:52

Takie wpisy to ja kocham :) Gdyby były jeszcze trochę bardziej obszerne byłby cud miód :D

artur9010   3 #4 21.08.2016 19:53

TL;DR, ale obrazki fajnie wyglądają to potem przeczytam :p

bravo   16 #5 21.08.2016 20:56

@Pangrys: Pierwotnie miało być bardziej szczegółowo, ale stwierdziłem że byłoby za ciężkie i została wersja midi :-)

czarnylas   13 #6 21.08.2016 21:12

Podziwiam jak można przylutować tak mały element nie uszkadzając przy tym sąsiadujących podzespołów, ja to bym musiał najpierw wypić 10 cl.w celu wyeliminowania efektu drżenia rąk.

bravo   16 #7 21.08.2016 21:33

@czarnylas: musiałem stabilnie podeprzeć sobie dłonie, ale bez odpowiedniego grota to nie ma szans (stacja + grot 1mm).

bachus   19 #8 21.08.2016 21:41

Fajny wpis, lubię! Zastąpić "zwykłym" można, nic się tu nie zmieni. Poważnie ten zasilacz ruszył? To nie był opornik do pomiaru prądu tranzystora kluczującego?

bravo   16 #9 21.08.2016 22:08

@bachus: To jest obwód do wykrywania napięcia z przetwornicy, czyli czy mamy działającą przetwornicę. Układ podaje na wyjściu sygnał PG z niewielkimi opóźnieniami (np. ~300ms przy włączeniu zasilania). Generalnie napięcia cały czas były poprawne i zasilacz działał prawidłowo - brak było tylko sygnału kontrolnego, spowodowany przez przepalony rezystor na wejściowym dzielniku pomiarowym. Zerknij sobie na notę PS244.

bachus   19 #10 21.08.2016 22:38

@bravo: ok, dzięki za info z elektroniką nie mam kontaktu już z 15 lat.

__Tux__   12 #11 22.08.2016 07:59

@bravo: Udało się złożyć zasilacz tak, żeby nie zostały jakieś części :-) ?

  #12 22.08.2016 08:24

No ładnie, fajny wpis. Nie wiedziałem, że przy hauście samozaparcia da się takie rzeczy naprawiać. Ile czasu zajęła naprawa? Rozebranie + wytropienie usterki + przelutowanie + sprawdzanie?

muska96   8 #13 22.08.2016 10:06

@bravo: Świetny wpis! Miałeś szczęście, że to tylko dioda i rezystor z obwodu pomiaru napięć, a nie któryś z tranzystorów MOSFET, bo te lubią być bardzo drogie. W sumie to zastanawiam się, czy nie zrobić jakiegoś poradnika dot. naprawy przetwornic - jakie elementy najczęściej ulegają uszkodzeniu, jak szukać usterki, które elementy zużywają się pod wpływem czasu itp. Ale do tego będę musiał wić sobie kilka przetwornic i zasilaczy.

  #14 22.08.2016 10:25

Bardzo przyjemny wpis, ostatnio mnie też coraz więcej elektrośmieci udaje się naprawić. Na koncie mam już 2 monitory, xperia s (wymiana gniazda microusb to prawdziwa męczarnia), elektroniania i wysłużony już odtwarzacz dvd.

O ile popsuty rezystor był widoczny, o tyle możesz przedstawić metodologię zlokalizowania popsutej diody?

enkidu   2 #15 22.08.2016 10:36

Super wpis, poczułem się jak kilka lat temu jak studiowałem jeszcze elektronikę, od tego czasu zero kontaktu :D

#r2d2#   10 #16 22.08.2016 11:03

Super wpis, uwielbiam takie. Ale mogłeś trochę bardziej szczegółowo opisać naprawę.

jata   2 #17 22.08.2016 11:14

A co mogło być przyczyną tej usterki??
Przepięcie w sieci??

Rauliki   1 #18 22.08.2016 11:40

Jak odlutowales ten maly opornik zeby go nie uszkodzic (z hdd)?

Domker   6 #19 22.08.2016 12:06

Ja już bym takiemu zasilaczowi nie ufał :D
Raz się zepsuł to i drugi raz może.
Na szczęście na swój mam 10 lat gwarancji to powinno wystarczyć ^^

Perceptron   8 #20 22.08.2016 13:31

Fajny wpis.
Te 2 lata od schowania do szafy napawają mnie optymizmem.
Sam mam takiego delikwenta co ...rok temu odmówił posłuszeństwa, został zastąpiony i czeka na zabieg jak w państwowej służbie zdrowia.
U mnie poszedł pewnie układ PP, bo przez jakiś czas po wyłączeniu zasilacza nie był w stanie podać 5V na "5V_SB". Jak się odczekało odpalał i napięcia też stabilne jak skała, a zasilacz ma dobre 8 lat.

  #21 22.08.2016 16:07

Co do lutowania SMD, od dłuższego czasu stosuję metodę wleczenia za grotem pasemka stopu, którym "omiatam" lutowanego pina. Działa na rezystory, kondensatory, diody "turlaki" itp., nawet większe tranzystory OK, ale nie chciałbym próbować tego ze scalakami.
Ciekawe jednak co się stało, że diodę przebiło. Czy typowe zmęczenie komponentu cyklami on/off, czy może coś jeszcze tam jest?
I ja mam jakąś awersję do krytycznego sprzętu jeżeli jest tak zapaćkany. Zauważmy, że te paciaje z silikonu sanitarnego niczego nie chronią poza widokiem słabych komponentów.

  #22 22.08.2016 16:08

Wielkie dzięki za ten wpis, aż chce się czytać.

Ta tematyka trafia do człowieka. Oby więcej takich wpisów :D

Indy   8 #23 22.08.2016 16:25

Fajnie byłoby, gdyby istniały instrukcje serwisowe dla zasilaczy, wskazujące na punkty pomiarowe i pozwalające na szybkie zdiagnozowanie usterki. Pomarzyć można ;)

  #24 22.08.2016 17:06

Kolejny g...ny OCZ. Onie sie sypia ostatnio non stop. Gdzie nie czytam: zwalony OCZ.

Alladynek   7 #25 22.08.2016 17:07

@Olippo669 (niezalogowany): Z elektroniki jestem totalnym amatorem, ale dla mnie lokalizację takiego elementu można wykonać na 2 sposoby: 1) napięciowy - na sprawnej diodzie będziesz mieć spadek napięcia ok 0,6V; 2) beznapięciowy - zwykłym multimetrem sprawdzasz czy dioda w jednym kierunku ustawia się zaporowo (powinna być funkcja w multimetrze do sprawdzania diod);

bravo   16 #26 22.08.2016 17:22

@__Tux__- No zostały - spalone części :-)

@Anonim (niezalogowany) - Nie mierzyłem czasu, ale najwięcej mi zajęło znalezienie diody ;-)

@muska96- Akurat ta usterka była prosta i mało inwazyjna, jak by było coś poważniejszego to pewnie bym się za to nie zabierał, szczególnie jak by było od strony sieci. A wpis o przetwornicach chętnie poczytam.

@Olippo669 (niezalogowany) - Szedłem od kości PS244 od nóżki PGI i widząc jakie są elementy - dokładnie je oglądałem pod lupą. Na diodzie też zauważyłem malutki ciemny punkcik. Po jej wylutowaniu zmierzyłem miernikiem i już było wiadomo. Dioda ma przewodzić tylko w jedną stronę, jak jest inaczej, to już wiadomo.

@#r2d2#- Obiecuję, że następnym razem będzie więcej szczegółów :-)

@jata- Moim zdaniem taki był przewidziany żywot diody, która po ustalonym czasie (gwarancja była na 5 lat) miała paść, a że komputer był włączany często... Następnie zaczął płynąć duży prąd przez opornik, który się przepalił i tyle.

@@Rauliki- No jak na złość nie miałem odpowiedniego grota (takie widełki) i musiałem się posiłkować dwiema lutownicami na raz. Grzanie doprowadziłem z obu stron i po roztopieniu spoiwa - podniosłem do góry. Ale muszę sobie kupić na przyszłość, albo najlepiej zrobię sobie taki!

@@Domker - ja spokojnie ufam - w sekcji stabilizacyjnej oraz w przetwornicy nic nie było tykane, bo tam wszystko działało. Naprawa dotyczyła tylko wykrywania napięcia. W najgorszym wypadku zabraknie sygnału PG i zasilacz się wyłączy.

Dzięki wszystkim za odwiedziny!

Autor edytował komentarz w dniu: 22.08.2016 18:22
Rauliki   1 #27 22.08.2016 17:29

Dzięki. Mam tylko jedną lutownicę i próbowałem jakoś przenieść rezystor przy przeróbce stacji Samsunga do Amigi. Najwyraźniej coś zepsułem bo nie działa. Jak masz dwie to da jakoś radę

edmun   12 #28 22.08.2016 17:50

@muska96: ja bym z chęcią taki dodał sobie do biblioteczki wiedzy

Virtus   7 #29 22.08.2016 17:58

@bravo: Mógłbyś dać zdjęcie lutownicy z tym grotem?

bravo   16 #30 22.08.2016 18:15

@Virtus: Aktualnie posiadam taki standardowy z taką kolbą: http://goo.gl/vR1U59
Tania stacja lutownicza WEP 937D+, ale na moje potrzeby idealna.
Muszę załatwić sobie grot typu R i RT, właśnie do wyciągania elementów SMD. Najlepszy byłby HotAir, ale więcej by się kurzył niż bym z niego korzystał :-)

Autor edytował komentarz w dniu: 22.08.2016 18:18
ra-v   12 #31 22.08.2016 19:40

Czasem tak jest, że części do wymiany kosztują 3 zł, a szukania jest na 2 popołudnia :)
Trzeba być elektronikiem z pasji albo zawodu, żeby szukać takich rzeczy.
Osobiście pewnie bym sprzedał go jako uszkodzony w licytacji na Allegro.

Emigrant Sebastian   8 #32 22.08.2016 21:20

@bravo: "To jest obwód do wykrywania napięcia z przetwornicy, czyli czy mamy działającą przetwornicę. Układ podaje na wyjściu sygnał PG z niewielkimi opóźnieniami (np. ~300ms przy włączeniu zasilania). Generalnie napięcia cały czas były poprawne i zasilacz działał prawidłowo - brak było tylko sygnału kontrolnego, spowodowany przez przepalony rezystor na wejściowym dzielniku pomiarowym. Zerknij sobie na notę PS244."

Czuję się nieswojo gdy pomyślę iż samopoczucie moich postaci w Diablo III zależne jest od tego tam.

Świetny wpis, zero gwiazdorzenia, przejrzysty język, od dzisiaj nie wypierniczam już nic co brało udział w blaszakach moich.

  #33 23.08.2016 07:42

Pytanie lamera:

"Pomiar omomierzem potwierdził uszkodzenie (przerwę w obwodzie). "

Jak takie coś się robi? Może chociaż coś prostego nauczę się naprawiać jak, bo jednak sporo rzeczy się wyrzuca, bo "nie działa" a nieraz naprawa może się równać z wymianą elementu.

bravo   16 #34 23.08.2016 17:02

@CX-80 (niezalogowany): "Jak takie coś się robi?"
Sorry, ale po tym pytaniu radzę, abyś nie zabierał się za naprawy elektro-sprzętów, a przynajmniej nie bez nabycia wiedzy z podstaw elektrotechniki i elektroniki - dla własnego bezpieczeństwa.

Autor edytował komentarz w dniu: 23.08.2016 17:03
Dementor   29 #35 23.08.2016 18:11

Świetny wpis. Czyta się jednym tchem. Swoją drogę trzeba mieć świętą cierpliwość do takich kompleksowych napraw :D

bravo   16 #36 23.08.2016 19:06

@80mentor: No trochę cierpliwości trzeba, a ile cierpliwości musiał mieć zasilacz przez te 2 lata na dnie szafy ;-)

WODZU   16 #37 23.08.2016 19:28

@Domker: Nie ma reguły. Mi bodaj 2 lata temu klęknął zasilacz Corsair 620HX - niestety już po gwarancji. Przypuszczam że padła jakaś pierdółka, ale musiałem go szybko zastąpić innym (Seasonic G650). Korsarza muszę jednak dać koledze do naprawy, bo szkoda takiego PSU.

@CX-80 (niezalogowany): Proponuję stopniowo zapoznawać się z treścią tego kanału https://www.youtube.com/channel/UC3TAqUdZld-6B76GqrFEV8g Zaczyna się od zupełnych podstaw. Sam nie jestem elektronikiem, ale prowadzący go człowiek rozjaśnił mi w głowie bardziej, niż lata przymusowej fizyki w szkole.

Autor edytował komentarz w dniu: 23.08.2016 19:35
bravo   16 #38 23.08.2016 19:51

@WODZU: rzeczywiście fajny kanał. @CX-80 - to jest to czego Ci potrzeba.

SebaZ   15 #39 07.09.2016 12:05

Kawał dobrej roboty i wpisu. Szczerze mówiąc mnie by się nie chciało już w to bawić :P Jeszcze napuchnięty kondensator wymienić to jak Cię mogę, ale szukać drogi i małego pierdka przepalonego szukać. Szacun!

  #40 27.11.2016 12:51

Wielkie dzięki za opis naprawy, u mnie ten sam zasilacz, ta sama usterka. Po wymianie 2 elementów SMD zasilacz jak nowy :). U mnie niestety przepalenie opornika nie było tak widoczne jak u Ciebie, wiec bez Twojego opisu miałbym duże problemy z namierzeniem usterki. Pozdrawiam.

bravo   16 #41 28.11.2016 16:52

@Anonim (niezalogowany): Fajnie, że się przydało. Pozdrawiam!