Strona używa cookies (ciasteczek). Dowiedz się więcej o celu ich używania i zmianach ustawień. Korzystając ze strony wyrażasz zgodę na używanie cookies, zgodnie z aktualnymi ustawieniami przeglądarki.    X

e-Deklaracja na Ubuntu, czyli jak rozliczyć się z podatku na linuksie

Początek nowego roku to czas nowych inicjatyw i działań, ale również podsumowań. Do jednego z tych podsumowań należy rozliczenie się z podatku za rok ubiegły. Czas na to mamy ograniczony w zależności od rodzaju wykonywanej pracy (czyli rodzaju formularza który musimy złożyć) do odpowiednio: 31 stycznia (PIT 16A, 19A, 28), 28 lutego (PIT 40, 40A), lub też najczęściej 30 kwietnia (PIT 36, 36L, 37, 38 i 39). Szczęśliwi Ci którzy dochodu nie mają i rozliczać się nie muszą:D Dla pozostałych wiele organizacji udostępnia różnego rodzaju programy do rozliczeń. Zazwyczaj udostępnienie programu jest powiązane z tym, że nasz 1% podatku jest przekazywany na rzecz konkretnej fundacji z automatu wklepanej w formularz rozliczenia. Ponieważ cenię sobie wolność wyboru, czasem sam chciałbym coś wklepać w te właśnie miejsce. Z pomocą przychodzi program e-Deklaracja do pobrania chociażby z portalu DP. Instalacja e-Deklaracji na Windows jest banalnie prosta. gdyż zazwyczaj wszystkie potrzebne programy dodatkowe są już w systemie dostępne. Na Linuksie mamy to nieszczęście, iż środowisko Adobe AIR nie jest aktualizowane i dla posiadaczy systemów 64 bitowych (ja taki mam) wymagało drobnej "grzebaniny" z plikiem instalacyjnym dla systemów 32 bit. Ostatnio jednak spotkałem bardzo sympatyczną metodę instalacji środowiska na stronie pomocy Ubuntu.

AKTUALIZACJA: W czwartym komentarzu przedstawiam prostszą metodę instalacji (która w moim przypadku z nieznanego mi powodu nie powiodła się i z dlatego postąpiłem zgodnie z procedura opisaną poniżej).

Na początek zaczynamy standardowo..

dla większości z platform. Ściągamy plik instalacyjny e-Deklaracji np. ze strony:

http://www.dobreprogramy.pl/eDeklaracje-Desktop,Program,Linux,17250.ht...

Dobrze, żeby zapisać go w miejscu takim, abyśmy łatwo mogli go odnaleźć do późniejszej instalacji.

Jak pewnie większość z Was zauważy na dole strony do której przekierowuje link pobierania jest napisana wyraźna informacja o tym, iż do poprawnego działania konieczne jest zainstalowanie Adobe Reader w wersji co najmniej 8.1.4, oraz środowiska Adobe AIR i Flash. Musimy to zatem wykonać.

Zaczynamy zatem od tego co linuksiarze lubią najbardziej, czyli odpalenie konsoli. Możemy to zrobić używając skrótu Ctrl+Alt+T.

W kolejnym kroku musimy dodać repozytorium co robimy poleceniem:

- sudo apt-add-repository 'deb http://archive.canonical.com/ $(lsb_release -sc) partner'

Po jego dodaniu aktualizujemy i instalujemy Flash Player oraz Adobe Reader poleceniem:

- sudo apt-get update && sudo apt-get install flashplugin-installer acroread

Po tej operacji do poprawnego działania e-Deklaracji brakuje nam jeszcze pakietu Adobe AIR. Zaczynamy zatem od pobrania go poleceniem:

- wget http://airdownload.adobe.com/air/lin/download/latest/AdobeAIRInstaller.bin

Wydajemy komendę aby zmienić pobrany plik na plik wykonywalny:

- chmod +x AdobeAIRInstaller.bin

I dokonujemy instalacji poleceniem:

- sudo ./AdobeAIRInstaller.bin

Na stronie pomocy Ubuntu spotkałem jeszcze informację o fakcie iż mogą wystąpić problemy z gnome-keyring, lub Portfel KDE w trakcie instalacji. Zostanie ona wtedy przerwana, a program nie zostanie zainstalowany. Mi konsola wyrzuciła problemy z gnome-keyring. Aby się ich pozbyć musimy wykonać jedną z dwóch operacji w zależności czy mamy system 32 bit, czy 64 bit. Polecenia są następujące:

Dla 32 bit wpisujemy kolejno w terminalu:

- sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
- sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0

natomiast dla 64 bit:

- sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
- sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0

Po zakończeniu wykonywania tych poleceń ponownie odpalamy instalację AdobeAIR poleceniem:

- sudo ./AdobeAIRInstaller.bin

Tym razem u mnie przebiegło wszystko bez problemów. Mam nadzieję, że u Was również:D W tym momencie mamy już zainstalowane wszystkie wymagane pakiety, zatem wracamy do naszego ściągniętego pliku .air z e-Deklaracją. Klikając na nim (lub wydając odpowiednie polecenie konsoli) uruchamiamy instalator, który gładko i sprawnie przeprowadza nas przez proces instalacji.

Tym sposobem mamy gotowy prosty program do rozliczenia podatkowego z naszym Urzędem Skarbowym. Nie pozostaje mi zatem nic innego jak życzyć bezbłednych rozliczeń i dużych zwrotów.

P.S. Na stronie internetowej e deklaracji do probrania są pliki pomocy w razie gdyby ktoś miał problemy z obsługa samego programu.

Źródła:

http://www.finanse.mf.gov.pl/systemy-informatyczne/e-deklaracje/do-po...

http://www.ubuntu-pomoc.org/ubuntu-12-04-instalacja-oprogramowania-ado... 

linux porady inne

Komentarze

0 nowych
LordRuthwen   5 #1 15.01.2013 13:48

Ale rozliczyłeś się tak i wysłałeś/wydrukowałeś pita?
Bo ja w tamtym roku próbowałem takie czary zrobić na Debianie x64 i program działał poprawnie do momentu próby wysłania pita lub próby jego wydrukowania... a potem od nowa :P
P.S. Adobe Air dla Linuksa jest już niewspierane.

4lpha   9 #2 15.01.2013 14:11

Ale wciąż działa.
I wciąż przez Adobe Air można odpalić Iplę dla Linuksa.

LeserGD   5 #3 15.01.2013 14:42

Na Debianie x86_64 (testing) wczoraj bez problemu udało mi się wysłać PIT. W poprzednich latach też nie miałem z tym problemu na innych distro.

Chemical Attack   4 #4 15.01.2013 15:00

Dokładnie tak jak napisaliście, Adobe AIR nie jest już wspierane, niemniej stara wersja jest wystarczająca. Co do drukowania nie mam żadnego problemu. Wysyłać jeszcze nie próbowałem, bo czekam na rozliczenie od pracodawcy.

Okazuje się też że jest jeszcze prostsza metoda instalacji e-Deklaracji.. wystarczy kliknąć w napis zainstaluj na obrazku na środku strony (ten z symbolami systemów):

http://www.finanse.mf.gov.pl/systemy-informatyczne/e-deklaracje/do-pobrania/-/as...

Wtedy instalacja wszystkich komponentów powinna pójść gładko. Właśnie.. powinno bo mi wywalało jakiś błąd.

Autor edytował komentarz.
  #5 15.01.2013 17:00

Ja od lat korzystam z http://pit.dobry.pl/index.php?plik=pliki na wine. I nawet nie muszę uzupełniać danych osób które rozliczam (rodzina). Wystarczy wskazać poprzedni plik z danymi.

beduin89   2 #6 15.01.2013 17:31

A ja to chyba nie będę się bawił w instalację czegokolwiek. Po prostu wejdę na stronę http://www.e-pity.pl i z wykorzystaniem ulubionej przeglądarki wypełnię swoją deklarację :)

KyRol   17 #7 15.01.2013 17:36

Ale nie tylko Air jest niewspierany, Adobe Reader też nie jest...

WODZU   16 #8 15.01.2013 18:13

Jak ja chciałbym płacić dziesięcinę :)

  #9 15.01.2013 18:50

@WODZU
Tak w ramach czepiania się: Nie chciałbyś. Dziesięcina, czyli rodzaj podatku na proboszcza parafii, którą składali parafianie wynosząca 1/10 plonów, lub dóbr wyprodukowanych, czyli jakby nie liczyć całkiem sporo. Dodatkowo dziesięcina w żaden sposób nie zwalniała z pańszczyzny, czy innych podatków. Jestem więc pewien, że na tace dajesz znacznie mniej niż 1/10 swojej pensji, o ile w ogóle jesteś wierzący.

Quest-88   15 #10 15.01.2013 19:27

Nie dziwię się, że zwykli użytkownicy powielają plotki o problematycznej obsłudze Linuksa skoro "społeczność aż tak utrudnia instalację programu. Ja e-Deklaracje zainstalowałem tak jak to opisał @Chemical Attack w czwartym komentarzu. Szybko i bezboleśnie. I było to w 2010 od razu po wydaniu programu. Od tego czasu rozliczam się tylko w rządowej aplikacji (żeby mieć pewność, bo skarbówki nie obchodzi zła implementacja protokołu w programach firm trzecich), i tylko pod Linuksem.

Jedyne co mnie ostatnio trapiło to problem z certyfikatami, ale problem rozwiązałem z pomocą kancelarii MofNetu.

http://ooblog.pl/2013/01/12/e-deklaracje-problem-z-certyfikatami-rozwiazanie/

WODZU   16 #11 15.01.2013 20:10

@X.A.N.
Niestety moim proboszczem jest Urząd Skarbowy i ZUS, którym oddaję w sumie ponad 4 dziesięciny (19% PIT i 23% VAT).

Chemical Attack   4 #12 15.01.2013 22:23

@Quest-88
Zasadniczo najbardziej problematyczna jest nie sama instalacja e-Deklaracji, ale komponentów Adobe.. Metoda podana w czwartym komentarzu jak pisałem jest prosta, ale u mnie nie chciała pójść. Być może własnie przez obecność systemu 64 bit. Jak sam zatem widzisz linuks nie jest taki straszny nawet dla zwykłego użytkownika. Pod warunkiem, że dojdzie do tego co Ty:D

  #13 24.01.2013 20:40

U mnie pomimo poprawnego zainstalowania na Ubuntu 12.04.1 LTS 64-bit program e-deklaracje nie wyświetla wszystkich okienek dot. danych osobowych, nie można zapisać danych wpisanych czy wybrania kraju i województwa.

  #14 17.02.2013 21:45

mam to samo, klikam, aby otworzyło mi PIT/0 i nie otwiera mi formularzu dotyczącego ulgi dla dzieci (tylko połowa tego pitu się otwiera). próbowałam wszystkiego. dlaczego się tak dzieje i co na to poradzić?

  #15 28.02.2013 11:57

@X.A.N.
...podatki: wówczas "dziesięcina", dziś około 83%.
Wolności obywatelskie: wowczas tylko pańszczyzna, dziś ponad pięciokrotny spadek poziomu wolności obywatelskich, zresztą nie wiadomo jak to dokładnie liczyć i niektórzy analitycy podają większe liczby.
Jesteś, X,A.N. typowym dowodem porażki państwowej-publicznej edukacji. Bez urazy, to nic osobistego. dziś trudno dokopać się do faktów, ale myślenie nie boli. Wiesz co znaczy pojęcie "pożyteczny idiota", i kto i po co je wymyślił? Powszechnie znana postać historyczna...

  #16 08.06.2013 13:33

E-deklaracje to rządowa aplikacja i wedle odpowiedzi od Ministerstwa Finansów nie będzie przejścia na wyższą wersje AIR, bo jak się okazuje w Polsce GNU/Linux używa ponad 20% użytkowników komputerów. To dobra wiadomość.
@X.A.N.
Teraz jest podatek węglowy, płacony praktycznie od wszystkiego, a wiesz komu, bo nie Państwu.
Otóż ten podatek płacimy prywatnym amerykańskim bankom.

Ground21   8 #17 24.02.2015 14:33

@Chemical Attack: to nie jest wystarczający argument, że stara wersja jest wystarczająca. Nawet jeśli na pewnych komputerach na pewnych konfiguracja program uda się odpalić. Stare oprogramowanie to utrata bezpieczeństwa. Aplikacja powinna być tak zrobiona, żeby śmigała na najnowszej wersji Ubuntu/Fedory/Archa z najnowszymi paczkami i nie sprawiała żadnych problemów. Tymczasem pieniądze zostały wydane na aplikację, która działa bezproblemowo tylko na Windowsach. Żenujące :(

  #18 09.11.2015 15:03

A ja podjąłem decyzję, że tym razem pity 2016 rozliczę już w internecie. Mam dość chodzenia do biura rachunkowego, po części wynika to z niechęci przed biurokracją i urzędowymi papierami ale może faktycznie e deklaracje są rozwiązaniem.

  #19 28.12.2015 13:54

Salut Szanownym Koleżeństwu !
Kto może wskazać zaproponować dobry program do PIT za 2015 ?
Sstem Mageia 5, 64-bit.
W tamtym roku (2014/2015) jeszcze się mi udało z e-pity, ale teraz chyba trzeba
mocniej w systemie pogrzebać (?) albo poszukac czegos innego ....

  #20 29.12.2015 19:09

@Chemical Attack: Linux jest na wysokim poziomie na dzisiejsze czasy. W tej chwili nie problemem jest Linux a to, że Adobe postanowiło wypiąć cztery litery na niego (i tak dziadowo wspierali ;) ), a ktoś wpadł na "genialny" pomysł by napisać kluczową dla każdego aplikację wymagającą dwóch najbardziej pokrzaczonych rzeczy w multiwersum, Air i Reader...

Nie wiem czy nie lepiej i szybciej jest znaleźć alternatywę. Na ostatecznego znaleźć druki (tudzież stworzyć) jako PDF edytowalny i huzia...