Błąd przepełnienia bufora w XnView

Strona głównaBłąd przepełnienia bufora w XnView
02.04.2008 11:10

Firma Secunia opublikowała komunikatbezpieczeństwa dotyczący luki w komponencie odpowiedzialnym zawyświetlanie pokazu slajdów przeglądarki graficznej XnView. Zdaniem specjalistów z firmy Secunia odtworzenie specjalniespreparowanej prezentacji slajdów może dać możliwość"wstrzyknięcia" na komputer ofiary dowolnego szkodliwego kodu. Toza sprawą niekontrolowanej długości parametru FontNameprzechowywanego w pliku o rozszerzeniu sld. Gdy przechowywana tamwartość jest zbyt długa możliwe jest występowania błęduprzepełnienia bufora. Luka występuje w wersjach 1.92, 1.92.1, niewykluczone, że również w starszych. Użytkownikom korzystającym z "dziurawej" wersji XnView zaleca sięjak najszybszą aktualizację oprogramowania do najnowszej wersjioznaczonej symbolem 1.93.4, w której przedstawiony błąd niewystępuje. Dostępna jest ona w vortalu dobre programy w dzialePROGRAMY -> Grafika -> Przeglądarki graficzne

Udostępnij:
Wybrane dla Ciebie
Komentarze (6)