Debian 4.0 r4 wydany, Lenny 5.0 już niebawem

Debian 4.0 r4 wydany, Lenny 5.0 już niebawem27.07.2008 17:00
Adam Wróblewski

Ukazała się kolejna aktualizacja stabilnej gałęzi Debiana 4.0, znanego pod nazwą kodowąEtch. Wnosi ona głównie poprawki bezpieczeństwa, drobnych jak ipoważniejszych błędów. Pojawiła się też nowa wersja instalatora, wktórej wyeliminowano usterki związane z instalacją systemu poprzezsieć, w już istniejącej macierzy RAID oraz pod architekturąPowerPC64. Dodano sterowniki dla kart graficznych GeForce z serii8, intel 965GM, 965GME, G33, Q35 i Q33 w serwerze X Window System(X.Org), a także, ze względu na bezpieczeństwo i sposóblicencjonowania, usunięto pakiety glimpse, dcc oraz maxdb-7.5.00natomiast aboot i sysvinit zyskały wsparcie dla jąder powyżej2.6.23. Ponadto, pomimo obecności kernela w wersji 2.6.24, nadaldomyślną pozostała seria 2.6.18. Szczegółowa lista zmian jestdostępna w oficjalnym ogłoszeniu. Równocześnie trwająprace nad wersję 5.0 Debiana Lenny, pochodzącego z testowej gałęzidystrybucji. Parę dni temu Luk Claes, opiekun projektu, ogłosiłzamrożenie, w przeciągu najbliższych dni, drzewa Lenny. Oznacza to,że deweloperzy mają już zaledwie parę dni na przesłanie swoichpakietów twórcom, jeżeli chcą, aby zostały one uwzględnione wnastępnej wersji Debiana, gdyż dalszej kolejności autorzy skupiąsię jedynie na załataniu około 360 błędów. Wśród pozostałych dowykonania zadań, znajdziemy natomiast między innymi usprawnienie,aby zarówno skrypty pre, jak i post instalacyjne, pracowały wkonfiguracji, w której /bin/sh odnosi się do tzw. dasha, a takżeaktualizacje informacji na temat aktualnego stanu wszystkich 12architektur oraz optymalizacji skryptów startowych init.d. W chwili pisania materiału, nie zostały udostępnione płytyinstalacyjne z wersją r4 systemu. Podobnie jak to miało miejsce wprzypadku poprzednich aktualizacji, osoby pragnące uaktualnićsystem nie będą musiały na nowo instalować systemu, lecz będą mogłyto uczynić korzystając z APTa bądź innego systemu zarządzaniapakietami. Premiera wersji 5.0 Lennego planowana jest we wrześniu.Należy jednak pamiętać, że okres ten może się przedłużyć, biorącpod uwagę czas przygotowywania poprzednich wersji z gałęzistabilnej systemu.

Źródło artykułu:www.dobreprogramy.pl
Oceń jakość naszego artykułuTwoja opinia pozwala nam tworzyć lepsze treści.
Udostępnij:
Wybrane dla Ciebie
Komentarze (65)