Strona używa cookies (ciasteczek). Dowiedz się więcej o celu ich używania i zmianach ustawień. Korzystając ze strony wyrażasz zgodę na używanie cookies, zgodnie z aktualnymi ustawieniami przeglądarki.    X

Specjalista ds. teleinformatycznych — UPS'y, switche, kamery i RAID cz.76

W grudniu pisałem o reorganizacji ustawień szaf serwerowych. Oczywiście jak to bywa w przypadku służby zdrowia nic nie mogę zaplanować od początku do końca i oczywiście projekt został rozpoczęty, a nie mogę go zakończyć bo ciągle coś. No, ale po kolei bo ostatnie dwa miesiące były dość pracowite.

Przekleństwo chwilowego braku prądu

Od jakiegoś czasu w budynkach 3 i 4 pojawiają się chwilowe (0,5-1 sek) braki prądu. Niby nic takiego, bo większość komputerów wyposażonych jest w UPS'y. Okazuję się jednak, że w budynku nr 3 (gdzie znajduje się laboratorium) połączenie z główną serwerownią musi być ciągłe i nawet sekundowe przerwy w łączności powodują zawieszenia się serwera laboratoryjnego, a co za tym idzie stacje robocze w laboratorium odmawiają posłuszeństwa. Dopiero ręczne ubijanie sesji połączeń (pomiędzy serwerem laboratoryjnym a głównym oraz pomiędzy stacjami roboczymi a serwerem laboratoryjnym) po odzyskaniu połączenia rozwiązuje problem. Niestety w ciągu ostatnich dwóch miesięcy takie przerwy zdarzyły się kilkukrotnie. Natomiast w budynku nr 4 (ta sama linia energetyczna) z przyczyn nie ustalonych przez naszego elektryka w ciągu miesiąca spaliły się 3 switche umiejscowione na korytarzach.

Oczywiście najprostsze rozwiązania przychodzą najpóźniej. Zamiast wkurzać się, szukać wrażeń i nie wiadomo czego jeszcze, wystarczyło każdą skrzynkę ze switchem wyposażyć w urządzenie UPS i wszystkie problemy zostały rozwiązanie.

r   e   k   l   a   m   a

A czemu ten nowy system działa tak wolno

Od wdrożenia systemu medycznego minęło sporo czasu, a jeszcze nie wszędzie są zainstalowane komputery. Do końca zeszłego roku wszyscy lekarze POZ mieli dostać komputery. Jakoś tak się zeszło, że ostatnie komputery były montowane dopiero teraz. Do tej pory w budynku nr 2, gdzie montowaliśmy owe stanowiska raz czy dwa trafiło się, że otrzymałem zgłoszenie, że system działa wolno. Zanim jednak zdążyłem zdiagnozować co się dzieje, wszystko wracało do normy. Niestety od czasu wdrożenia 5 kolejnych komputerów praktycznie codziennie coś się działo w tym budynku. Uszkodzenie komputerów wykluczyłem, uszkodzenie switchy wykluczyłem. Kable (praktycznie wszystkie posprawdzałem. Skontaktowałem się naszym dostawcą neta i VPN - tez wszystko w porządku. Normalnie idzie się zastrzelić - wszystko jest spawane a system kuleje.

Rozwiązanie problemu jak zwykle trywialne - jako główny switch w przychodni zamontowałem starego 3 COM'a o przepustowości 10 Mb/s, który w rzeczywistości (po sprawdzeniu małym programem - LAN Speed Test (swoją drogą to przydałoby się coś podobnego w naszej bazie danych) "wyciągał niecałe 8 Mb/s

W końcu XXI - mamy monitoring

W sumie to nie wiem jak to się stało, ale do tej pory nie potrzebowaliśmy monitoringu w szpitalu i nigdzie go nie było. No, ale co się odwlecze to nie uciecze. W związku z budową nowej wiaty podjazdowej dla karetek (spieprzonej od samego początku, albo ja się po prostu nie znam i tak ma być) należy tą wiatę wyposażyć w co najmniej 4 kamery, które będą na bieżąco monitorować ruch przy tej wiacie. Jakimś trafem przy budowie wiaty nikt o tym nie pomyślał i teraz należy takie kamery zamontować. Oczywiście zwrócono się z tym od mnie. Dlaczego? - No przecież jest pan informatykiem, a taką kamerę podłączy się do sieci komputerowej i po sprawie. Acha. No niech Wam będzie.

Sprawdziłem wiec jakie kamery można zastosować, jak to spiąć z naszą siecią. No, porządnie przygotowałem się do tego zagadnienia. Przedstawiłem dokumentację i kosztorys na mniej-więcej 8 tyś zł (4 kamery, switch z Poe, rejestrator ze sporym dyskiem twardym) i ... zostałem poinformowany, że jednak odbędzie się przetarg. No super.

Po jakimś czasie będąc w pracy otrzymuje informację, że przyjechali technicy montować kamery. Co? Jak? Gdzie? Wracam więc do macierzystego szpitala (byłem w drugim szpitalu na jakieś robocie, którą musiałem oczywiście przerwać), i wówczas dopiero się dowiaduje, że jakiś czas temu został ogłoszony przetarg, który już jest rozstrzygnięty a zwycięzca już wszystko ma ustalone poza miejscem gdzie ma podłączyć się do naszej sieci. Oczywiście osoba która opisała przedmiot zamówienia (bez konsultacji ze mną - bo po co?), ogłosiła postępowanie, wybrała najlepszą (znaczy najtańszą) ofertę jest nieuchwytna, bo przebywa na urlopie za granicą. A ja oczywiście musiałem w ciągu pół godziny zapoznać się z bredniami które ktoś napisał w przetargu i przygotować monterom miejsce w serwerowni na rejestrator i miejsce w skrzynce sieciowej na ich switcha. Musiałem również pokazać którędy mogą poprowadzić przewody, jak i gdzie mogą wpiąć się do mojej sieci.

Oczywiście osoba, która zrządziła mi taki los nie została pociągnięta do żadnej odpowiedzialności. Ech odechciewa się pracy w takiej jednostce. Koniec końców okazało się, że nie ma pozwolenia od konserwatora zabytków na umieszczenie kamer na zewnątrz i monitoringu jak nie było tak dalej nie ma.

Mały Raid, duży problem.

Na jednym z moich serwerów działa kilka maszyn wirtualnych, konkretnie 5. Jest to zwykły PC na AMD z dwoma dyskami spiętymi w Raid 1 (mirror czyli kopia lustrzana). Takiego RAID'a stosuje na wszystkich mich maszynach serwerowych od lat i praktycznie nigdy nie miałem problemów z utratą danych (z jednym, no może dwoma wyjątkami, ale o tym może kiedy indziej). Jeśli nawet jakiś dysk się uszkodził to się go wymieniało, system robił kopię na nowy dysk i po problemie. Tym razem zapowiadało się podobnie. Kilka dni temu komputer na którym "żyją" sobie owe maszyny wirtualne przestał być widoczny w sieci. Restart komputera (zwłaszcza że host to Windows) zawsze dobry jest:). Tym razem tak samo.

Niestety po kilku dniach sytuacja się powtórzyła. Nie zaświeciła mi się żadna lampka ostrzegawcza (ani w głowie ani w komputerze), że coś się dzieje z tym serwerem. Kolejny restart i wszystko działa bez problemu. Aż do zeszłego poniedziałku, kiedy to Windows się zawiesił a po restarcie nic się nie uruchomiło. Test BIOS'u przeszedł poprawnie i nic czarny ekran. No cóż, coś padło i trzeba się szybko tym zająć. Kopie zapasowe mam a wiec problemu wielkiego nie ma. Przywrócę cała maszynę wirtualną na innym serwerze i po problemie. Tak też zrobiłem. Żaden problem jak polityka backupu (o niej tez przydałoby się skrobnąć jakiś wpis) działa jak w zegarku.

Oczywiście ciekawość (i pełnione obowiązki) kazały mi sprawdzić co się tam "ugotowało". kolejne włączenie dało mi BSOD'a. Czyli Ram może szwankować, wymieniłem więc, odłączyłem dyski. Komputer zgłosił się bez problemu. Podłączyłem więc dyski, a tu zgrzyt głowicy dysku, przed chwilą zgrzytu nie było. Czyli jeden z dysków padł, odłączyłem go i przy jednym podłączonym dysku system powinien wstać. Nie wstał. Komputer wypluł tylko informację o krytycznym stanie Raid (normalne przy braku jednego dysku) a następnie poinformował mnie, że nie ma żadnego dysku. OK. Odpinam więc ten dysk a podpinam ten "zgrzytający". Oczywiście pojawia się zgrzyt, informacja o krytycznym stanie RAID i ... zaczyna ładować się Windows. Chwilę później pojawia się piękny BSOD. Hm czyli coś jest nie tak. Pamięć RAM testuje w innym komputerze. Jest ok. Hm.. Oba dyski do wyrzucenia? Raczej nie możliwe.

Wymontowałem więc wszystkie podzespoły z obudowy, porządnie wyczyściłem z kurzu i już bez powrotnego montowania w obudowie uruchomiłem komputer z obydwoma dyskami. Zgrzyt wydał mi się jeszcze głośniejszy niż poprzednio. Do dziwne jednak Windows wystartował, jednakże jeden z dysków delikatnie zgrzyta. Czyli jednak oba dyski do wymiany. Skopiowałem wiec z komputera co się dało (znalazłem wersję elektroniczną dokumentu nad który kiedyś pracowałem i go zgubiłem:)). Okazało się, że w tym jednym rzeczywiście głowica uszkodzona, a drugi ma jakieś 30% bad sektorów. Naucza na przyszłość - zwykłe dyski Seagate w pracy ciągłej 24/7 wytrzymują nieco ponad 2 lata.Następnym razem może z WD? Szybka wymiana dysków, postawienie systemu na nowo i po jakiś dwóch godzinach serwer gotowy z powrotem do pracy. Kolejna lekcja z dzisiejszej awarii - Kontroluj stan Raid'ów co najmniej raz na pół roku, bo raczej mało prawdopodobne jest, że oba dyski padły w jednym czasie.

-----
Na koniec oczywiście spis treści mojego bloga i zapraszam do moich wpisów. Polecam szczególnie
ten wpis, gdzie opisałem jak poprawnie formatować wpisy na blogu, bo niektóre pomimo świetnej treści formatowanie mają niepoprawne. Ponadto polecam ten wpis na forum gdzie Semtex opisał jak wrzucać grafikę na naszego bloga. Informuję także, że wszystkie grafiki, użyte w wpiisach są mojego autorstwa lub są dostępne w otwartej licencji lub są pobrane z oficjalnych stron podmiotów, o których wspominałem we wpisie. Pozdrawiam Shaki81 

windows oprogramowanie internet

Komentarze