Liczne błędy w routerach Linksysa – możliwe są zdalne ataki

Strona głównaLiczne błędy w routerach Linksysa – możliwe są zdalne ataki
21.04.2017 11:05
Liczne błędy w routerach Linksysa – możliwe są zdalne ataki

Wystawianie panelu administracyjnego w publicznej sieci to chybanajgłupsza rzecz, jaką może zrobić właściciel routera,szczególnie gdy to router działający na firmware producentaurządzeń z niższych półek. Po raz kolejny słyszymy o całejgamie różnych luk w popularnej rodzinie routerów Linksysa –Smart Wi-Fi (EA3500 Series). Niektóre z nich pozwalają nawet nazdalne uruchomienie kodu na urządzeniu.

bEKKtuth

Pod marką Smart Wi-Fi oferowanych jest obecnie ponad 20 modeli,od najtańszych jednopasmowych urządzeń standardu 802.11n poszybkie, dwupasmowe, wieloantenowe routery 802.11ac. Wszystkie onedzielą ze sobą to samo firmware, jedynie nieco inaczejskonfigurowane. I tym firmware zainteresował się ostatnio TaoSauvage z firmy IOActive, który we współpracy ze swoim kolegą@xarkesem znalazł tam wiele atrakcji.

Bazujące na linuksowym systemie oprogramowanie okazało sięnaprawdę dziurawe. Znaleziono w nim łącznie 10 luk, z którychsześć może zostać wykorzystane do zdalnych ataków przeznieuwierzytelnionych napastników. Dwie luki pozwalają na ataki DoSprzeciwko routerowi i wpędzenie go w cykl restartów –administrator zdalnie wówczas nic nie zrobi.

Kolejne podatności pozwalają obejść mechanizm uwierzytelnieniai zebrać wrażliwe informacje o routerze, włącznie z listąprocesów, podłączonych urządzeń USB, a nawet PIN-em dopołączenia Wireless Protected Setup. Można też sprawdzićkonfigurację zapory sieciowej, znaleźć informacje o korzystającychz routera urządzeniach w wewnętrznej sieci, czy wydobyć dane oserwerach FTP i SMB.

bEKKtutj

Co jednak najgorsze, napastnicy, którzy zdołali się zalogowaćdo routera, mogą bezpośrednio na nim uruchomić swój kod zuprawnieniami roota, a co za tym idzie, założyć sobie stałe,ukryte konto dostępowe.

Kto jest zagrożony?

Jak ustalono, na takie ataki podatne są następujące modelerouterów Linksysa: EA2700, EA2750, EA3500, EA4500v3, EA6100, EA6200,EA6300, EA6350v2, EA6350v3, EA6400, EA6500, EA6700, EA6900, EA7300,EA7400, EA7500, EA8300, EA8500, EA9200, EA9400, EA9500, WRT1200AC,WRT1900AC, WRT1900ACS oraz WRT3200ACM. Jednocześnie za pomocąwyszukiwarki Shodan.io wykryto w Sieci około 7 tys. podatnych naatak urządzeń, które mogą być przejęte. 11% z nich używałodomyślnych loginów i haseł, można się spodziewać, że szybkoprzestaną należeć do swoich właścicieli.

Łatek jeszcze nie ma, dostaliśmy porady

Informacje o podatnościach dostarczone zostały producentowi wstyczniu – i jak twierdzą badacze, od tego czasu współpracaukładała się bardzo dobrze. Minęły jednak trzy miesiące, apoprawionych wersji firmware wciąż nie ma. Linksys wydał jedynieoficjalnąporadę, w której zapowiada rychłe wydanie aktualizacji izaleca na podatnych urządzeniach włączyć automatyczneaktualizacje, wyłączyć Wi-Fi dla gości oraz zmienić domyślnehasło administratora.

Programy

Aktualizacje
Aktualizacje
Nowości
Udostępnij:
bEKKtuuf