Blog (30)
Komentarze (4.7k)
Recenzje (0)

Skansen w wersji LTS

Strona główna@Silny_OgorSkansen w wersji LTS
06.02.2021 18:51

Kojarzycie ten rubaszny rechot, który wydają z siebie użytkownicy Linuksa na wiadomość o błędach odnalezionych w Windows? Zazwyczaj są to dziury załatane jeszcze przed ich ujawnieniem, ale nikomu to nie przeszkadza w pajacowaniu i pisaniu "używam Linuksa, jestem bezpieczny". Zazwyczaj piszą to z błędem ortograficznym, ale nie bądźmy złośliwi. Zamiast tego zobaczmy, jak ma się podejście do bezpieczeństwa we flagowej wersji Ubuntu.

Zainstalowałem ostatnią wersję LTS, żeby upewnić się, że nie grożą mi plagi dręczące ponoć pospólstwo używające Windows. Wybrałem standardową instalację + aktualizacje, a po skończeniu sprawdziłem dla pewności, czy są jeszcze jakieś dodatkowe patche.

Nie ma.

bECgHTUD

Ubuntu napchało na dysk masę bloatu w postaci pierdaśnych offisów i jakichś dziwacznych aplikacji do robienia zrzutów ekranu, które wyłączają się po zrobieniu... jednego :-) Partycja / nabita jak bus do Lichenia, a ustawienia czułości trackpada nie działają na ekranie logowania. No dobrze, nie bądźmy małostkowi, przecież za darmo dostajemy system w wersji LTS, cymes malina, top Linuksowych topów.

Przystąpiłem do konfiguracji klienta poczty. Domyślnie w Ubuntu tę rolę pełni Thunderbird, (po)twór rodem z minionej epoki, ale dalej działający i zadowalający mniej wymagających klikaczy. Program wygląda nieco archaicznie nawet na tle Linuksowych GUI. Pomimo tego, że jestem przyzwyczajony do GNU zwyrodnień jeśli chodzi o UX z niesmakiem sprawdziłem, czy ten Thunderbird to aby na pewno kompilacja z tego stulecia.

717681

Widzicie ten skansen? Panie, Sierpiec to przy tym zagłębie Ruhry. Decydując się na Ubuntu w wersji LTS, wspieranej i łatanej przez lata tak długie jak broda RMSa, dostajecie klienta poczty, który jest jakieś 22 (dwadzieścia dwie, XXII) wersje do tyłu w stosunku do ostatniego wydania. Żeby się upewnić, że to nie pomyłka zrobiłem apt update i odpaliłem Ubuntu Software:

717683

Ile dziur i błędów oznaczonych jako high i critical odnaleziono w Thunderbirdzie od czasu wydania wersji 68.10.0? Każdy może sprawdzić sam: https://www.mozilla.org/en-US/security/known-vulnerabilities/thunderbi...

bECgHTUJ

Nie mam pojęcia, ile podobnych kwiatków kryje się w tej i innych desktopowych dystrybucjach Linuksa (szczególnie tych testowanych równie pieczołowicie co Arch i Manjaro), ale można spokojnie założyć, że to nie jedyny taki przypadek. Hej!

bECgHTVz