Nazewnictwo elementów GUI

Doszedłem do wniosku, że najwygodniej używa mi się formy nazewnictwa zgodnej z szablonem:
-3-4 literki poprzedzające typ komponentu
-nazwa ;)

Czyli przykładowo przycisk do zapisu nazwę:
btnSave
a kontrolkę typu TextBox na datę:
txtDate

Dlaczego tak jest mi najwygodniej? Ponieważ przy ogromnej ilości formatek/stron i komponentów na nich, często zapominam nazwy poszczególnych elementów. Zwykle jednak pamiętam ich typ. Dzięki temu szukając pola tekstowego wpisuję txt a podpowiadanie składni umożliwia mi bardzo szybkie odszukanie tego co jest mi potrzebne.

Nie stosuję tej metodyki do nazywania zwykłych zmiennych w stylu:
int iNumber
ponieważ często nie pamiętam typów zmiennych. Bardzo często najpierw wpisuję nazwę i dopiero wtedy patrzę jakiego zmienna jest typu. Do tego zmiennych posiadających zakres całej klasy mam zwykle mniej niż elementów interfejsu a ich typ bardzo często jest typem złożonym. Nie wydaje mi się, aby taki sposób ich nazywania pomógł mi w znaczący sposób, jak to ma miejsce w przypadku GUI.