Strona używa cookies (ciasteczek). Dowiedz się więcej o celu ich używania i zmianach ustawień. Korzystając ze strony wyrażasz zgodę na używanie cookies, zgodnie z aktualnymi ustawieniami przeglądarki.    X

Zasilacz OCZ ModXStream PRO u chirurga, czyli naprawa sygnału PG (PWR_OK)

Historia zaczęła się ponad dwa lata temu, kiedy to doznałem nieoczekiwanej sytuacji, co dla "komputerowca" oznacza szok i stan przed zawałowy. Komputer prawie umarł. Prawie, ponieważ po wciśnięciu "start" włączały się wentylatory i nic poza tym. Pierwsze próby zdiagnozowania rozpoczęły się od wypięcia wszystkich napędów i kart. Niestety nic się nie wyjaśniło.

Po wykluczeniu wszystkiego co można dołączyć do płyty głównej, podejrzany został tylko zasilacz. Metody "resetowania" w postaci odłączania całkowicie od zasilania nie pomogły. Po pomiarze napięć okazuje się, że są prawidłowe. Czyli wszystkie wartości są zgodne ze specyfikacją. W mojej głowie zabłysnęła żaróweczka "WDF!" i poszedłem spać.

Nazajutrz obudziła mnie myśl weryfikacji jeszcze jednego sygnału. Sygnału "PG" (Power Good), oznaczany też "PWR_OK". Sygnał ten jest podawany przez zasilacz i informuje płytę główną, że wszystkie napięcia są prawidłowe i można się uruchomić. Sygnał ten jest dostępny na pinie nr 8 złącza ATX, w kolorze popielatym lub białym. Mierząc napięcie między tym przewodem, a masą (kolor czarny) - powinno być 5V. W moim przypadku woltomierz wskazał wartość 0,07V - a jednak.

r   e   k   l   a   m   a

Otworzyłem więc moją Puszkę Pandory i pobieżnie dokonałem oględzin układu scalonego PS224, który odpowiada za kontrolę napięć wszystkich linii (3,3V-5V-12V) oraz monitoruje czy nie nastąpiło ich przeciążenie. Oględziny nie wykazały fizycznych uszkodzeń. Wówczas pilnie potrzebowałem uruchomienia mojego systemu i nie miałem czasu na zabawy w naprawę, więc postanowiłem zakupić nowy zasilacz, a OCZ wtrącić do izolatki w celu późniejszego obadania dokładniej sprawy (no 4,5 roku pochodził jednak).

Po ponad dwóch latach (!) od tego incydentu, wreszcie nadszedł czas na ostateczne rozwiązanie. Wyciągnąłem więc "oczko" z szafy i ponownie rozłożyłem, tym razem dokładnie wszystko - kawa na ławę. Dokładne prześledzenie drogi sygnału PG ujawniło przepalony (mała dziurka na środku) opornik R315 o rezystancji 10 ohm. Tym obwodem jest kierowane napięcie bezpośrednio z przetwornicy do wejścia PGI układu PS224.

Pomiar omomierzem potwierdził uszkodzenie (przerwę w obwodzie). Znając winowajcę wystarczy teraz tylko wymienić malutki rezystor SMD i po problemie. Ale zaraz zaraz, przecież nie mam takich rezystorów w składziku... Będzie konieczny przeszczep, a za dawcę posłużył mi stary dysk WD Caviar o pojemności 425,3 MB. Na płytce znalazłem kilka rezystorów o potrzebnej wartości.

Po wymianie opornika, przeszedłem do testów. Aby uruchomić zasilacz, musimy podać mu sygnał PS_ON (Power Supply On) przez połączenie pinu 14 (kolor zielony) do masy (GND). Do tego celu zrobiłem sobie zworkę z listwy pinowej i umieściłem we wtyczce ATX.

Start zasilacza i pomiar sygnału PG - niestety nadal nic. Po przyglądnięciu się wymienionemu elementowi stwierdziłem, że zbyt mocno się nagrzewa - cyna zaczęła się roztapiać na padach lutowniczych. Zapoznałem się wiec dalej z kolejnymi elementami i odkryłem uszkodzenie na diodzie prostowniczej D308. Okazało się, że prąd płynący w tym obwodzie przechodzi przez diodę i ładuje przez rezystor - kondensator. W chwili włączenia przez te elementy płynie większy prąd tylko w czasie ładowania kondensatora, tutaj brak prostowania napięcia przez uszkodzoną diodę powodował stały przepływ prądu przez obwód, który zamykał kondensator połączony z masą (GND).

Niestety nie znalazłem odpowiedniej diody w moich zasobach i byłem zmuszony zastosować element przewlekany. Dolutowaną diodę musiałem położyć na boku, aby się zmieściła - na szczęście udało się. Czas na test i pomiar napięć - udało się! Sygnał PWR_ON pokazał 5V, napięcia na wszystkich liniach się zgadzały - naprawa zakończona.

 

sprzęt porady hobby

Komentarze