Błąd w KDE

Strona głównaBłąd w KDE
23.01.2006 13:16
Redakcja
Redakcja

W KDE, jednym znajpopularniejszych menedżerów okien dostępnym pod Linuksa odkrytodość poważną lukę. Błąd tkwi w zintegrowanym w środowiskuinterpreterze języka JavaScript, używanym między innymi przezprzeglądarkę WWW Konqueror. Podczas dekodowania źle skonstruowanegoadresu URL zapisanego w formacie UTF-8 może dojść do błęduprzepełnienia bufora i w rezultacie do uruchomienia złośliwegokodu. Błąd dotyczy wersji od 3.2.0 do najnowszej- 3.5.0. Poprawka naprawiająca ten błąd została już opublikowana,ale zanim zostaną przygotowane zaktualizowane wersje dlaposzczególnych dystrybucji, może minąć trochę czasu.

Udostępnij:
Wybrane dla Ciebie
Komentarze (111)